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What is Southbeach Modeller?

● Comprehensive visual modeling software

● Built-in ideation rules engine

● Tailored for creativity, design, and analysis

● Distinct "situational improvement" methodology

● Enhances communication, facilitation, and understanding

● Adept at problem-solving, root cause analysis, and tackling wicked 
problems

● Addresses both human-centric and engineering design challenges

● Facilitates idea generation and stakeholder alignment

● Paves the way for improvement, innovation, and strategic pivoting

● Highly extensible and customizable rules engine



  

Download Modeller v4

● Full function free trial
– https://www.southbeachinc.com/software/download/index.html



  

User guides

● Provided with the installation:

– Southbeach Modeller v4 User Guide

– MyCreativity Reference v4 (Ideation engine)

● Updated engine with 30+ new problem-solving keywords
● Library content:

– 100s of curated ideation scripts and rulesets (MyCreativity)

– 3,000+ application-specific tags/groups (MyTags)

– 100+ pre-set grids, charts, and swimlanes (MyGrids)

– 200+ lists of reusable elements by topic (MyLists)



  

Upon installing the latest version of Modeller, users are greeted with a "Welcome" model. This model 
encompasses multiple panels including the Explorer, Toolbox, Notes, Creativity, and Reports. Within the 
Welcome model, are various sub-models, each presented on its distinct canvas tab. Furthermore, each of 
these panels offers multiple tabbed sections. For instance, the Toolbox not only presents a modeling palette 
but also features an array of resource libraries such as tags, grids, lists, creativity rule sets, cue definitions, 
and assistive tools.



  

Within the Welcome model, a "NEW in v4" tab showcases the expansive updates and functionalities. Users can 
access over 100 preset grids, charts, and swimlane templates, delve into more than 200 topic-specific lists with 
reusable elements, and benefit from hundreds of meticulously crafted ideation scripts and rule sets, alongside a 
vast repository of 3,000 application-specific tags and tag groups. The ideation engine has been revamped, 
introducing a 'cues' feature for combinatorial creativity. Search filters are now seamlessly integrated into all 
resource tree panels, also allowing efficient model searches via text or notation patterns. Additionally, the 
highlighter tool has been expanded to support all built-in pattern macros.



  

The versatility of Southbeach Modeller has been significantly enhanced with the addition of new v4 content. 
This includes tags and tag groups, grids/charts, topic-specific resource lists, and creativity rule sets that 
encompass areas like lateral thinking, ideation, and enterprise modeling, among others. Additionally, cues 
have been integrated to further expand its utility. All these resources are systematically organized in a 
hierarchical manner, allowing for easy filtering and searching within each panel tab. Users have the flexibility 
to modify or extend any content to suit their unique needs.



  

Following installation … from the Explorer panel, select "Models" and then open the "Getting Started" model. 

We recommend new users briefly go through each sub-model to acquaint themselves with the core 
functionalities of the tool. 



  

The creativity and reporting engine is a core feature of Southbeach Modeller. When one or more creativity 
scripts are activated and the engine is 'enabled' (as indicated by the power on/off icon on the toolbar), the 
ideation results are displayed in the creativity panel as users navigate through the model. Each model, 
including its sub-models, retains its own unique output. Users have the flexibility to create multiple sub-
models, creativity and reporting tabs. All generated content is stored within the model's .sbm file.



  

Navigate to the "Notation Guide" model within the Explorer panel. To open, either double-click it or use the 
"File open" menu option. This model offers a comprehensive overview of the Southbeach Notation. Version 4 
of Modeller is aligned with Southbeach Notation 1.0, serving as the reference implementation. It 
encompasses all notation shapes, modifiers, attributes, and types of effects/arrows.



  

The summary tab in the notation guide consolidates all the key features of Southbeach Notation 1.0 in a 
single handy model.



  

From the Explorer panel, select and open the 'Sample models'. These models, contributed by the Southbeach community, 
are not official products of Southbeach Solutions. To access the full library, navigate to File > Browse Examples Online. The 
screenshot demonstrates the capability to delve deeper into the model, exploring its sub-models and individual elements. 
Right-click on any model or sub-model within the Explorer. You can then drag sub-models or elements onto the canvas, re-
purposing them in a new model.



  

To access the comprehensive library of sample models, navigate to File > Browse Examples Online. While 
these models aren't official products of Southbeach Solutions, they serve as valuable illustrations of 
Modeller's diverse use cases. Please be aware that these examples were crafted during the release phases 
of versions 2 and 3, and therefore, may not showcase the enhanced features introduced in version 4.  



  

Open the model ‘Southbeach 101’ from the Explorer panel. This model is helpful in understanding the basics of 
the notation, e.g. useful and harmful elements, different kinds of effects, use of ‘tags’, ‘grids’, ‘separations’, 
‘creativity’ and ‘reports’. The image shows the user enabling a legacy ruleset from Southbeach v3 
(#consulting.reduce harmful).



  

In this screenshot, The right mouse (context) menu on an object is shown. All objects (agents and effects) 
have a context menu, giving quick access to all types and modifiers available in Southbeach Notation 1.0.



  

Open the ‘Big Picture’ model from the Explorer panel. It describes, visually, the range of applications for Southbeach 
Modeller. Unlike other visual modelling tools which typically support a specific methodology (UML, BPMN, EA etc), 
Southbeach Notation is a synthesis of existing visual methods. The core notation of useful and harmful elements, 
produces and counteracting effects, is often sufficient for a wide variety of modelling and analysis tasks, especially when 
combined with an appropriate ideation ruleset and/or domain-specific tags and grids/charts.



  

It is often unnecessary for all panels to be visible at once. For example, the user may only need the Toolbox 
and Canvas and not the model Notes, Creativity and Reports. The View menu and function keys provide 
control of panels and canvas zoom level. The mouse wheel also controls zoom level. 



  

In this screenshot, the user has ‘drilled’ down into the ‘sample models’ file revealing the sub-models and 
elements within each. This works with all models created by the user and forms, in effect, a reuse repository 
of visual patterns and elements.  Notice how hovering over a model or sub-model generates a visual ‘preview 
image’ without the need to ‘open’ the model for editing. 



  

The ‘drill down’ functionality of the repository/file tree is obtained by using the right mouse on any file. Right 
mouse plays a huge role in the Southbeach UI/UX. All panels, panel tabs, tree items, and panel, tab and 
canvas background, provide a right mouse ‘context’ menu. This greatly contributes to the usability of the 
software keeping secondary functions hidden when not in use. 



  

The Explorer provides a rich repository functionality for Southbeach. It is important therefore that it can be 
configured to point to any directory path or paths. See menu Tools – Options – Paths. Up to six paths can be 
defined. Network drives are supported. (Cloud services will be provided in an upcoming release.)



  

The Explorer panel provides five tabs. One points to the model/file tree itself. The others provide access to the 
current ‘open’ model: to the list of agents, list of effects (relationships between objects and to any tags/tag groups 
used in the model. The list of objects can be viewed and sorted in numerous ways. This capability to view a model as 
a list is a useful alternative to the visual representation, especially for large/complex models. In addition, the list can 
be copied to the clipboard for export to other applications. 



  

Here, the agent list in the Explorer panel is being used to sort the objects according to their ‘effect’ within the 
model, for example, ‘most improved’, ‘improving influence’, etc. The range of view and sort functions provides 
a simple way to explore any visual model and is often ‘good enough’ for simple idea development and and 
improvement suggestions.  



  

From the Explorer panel – Agents tab and Effects tabs, it is possible to view and sort the visual elements in 
numerous ways. This provides another important function. The right mouse context menu on an element in the list 
provides a ‘center and select’ function. The element is selected on the visual canvas. If the object is off-screen it is 
moved on-screen. This function is especially helpful when navigating large models and is one of many functions that 
give Southbeach Modeller its excellent scalability over a range of modelling tasks. 



  

As with the agent list in Explorer panel, so with the effect list. All relationships between objects are listed and 
can be viewed and sorted in numerous ways. Again, the list of effects can be exported via the system 
clipboard. The whole tree or a selected branch of the tree can be copied to clipboard. These functions make 
it extremely straightforward to extract information from the visual models for use in other documentation.



  

As well as supporting effects and relationships between objects, the notation supports ‘effects on effects’ and 
‘effects from effects’. For example, if object A produces (increases) B, an effect E can be added which 
counteracts the ability of A to generate the effect on B. The ability to list such indirect effects is useful in a 
range of applications. 



  

Tags extend the Southbeach Notation to any domain-specific applications. Every object in a model can be tagged in one or 
more tag groups. Both inclusive and exclusive tag groups are supported. All new models are created with three standard tag 
groups: type, symbol and number. From the Explorer panel, the user can add, remove or rename any tag, or can create a 
new tag group. Tags can also be used to create new agents of the same name. Simply dragging a tag to an object or to the 
canvas is all that is required. From the object’s right mouse menu its tags can be changed. The object inherits the tag group . 



  

Here, the user has clicked right mouse on an object. Any attribute of the object can be modified, including the 
tags and tag groups in which the object appears. On the left, a small section of the extensive tag library 
provided with the software is shown. There are over 3000 tags/tag groups, all searchable. Individual tags can 
be directly dragged to objects or to the canvas. Alternately, tag groups can be added to the model which 
makes them available via the Explorer views and sorts. 



  

As with all resource trees, the tag library is expandable at multiple levels of detail. The right mouse menu at a level will 
contain functions relevant at that level. Here, the top level menu provides the basic functions of collapsing and expanding 
the tree, and editing the tag definitions. Right mouse on a tag group, for example, provides an option to copy the entire 
group to the model, where it will then appear in the Explorer panel views. Having tag groups ‘in’ the model itself (not just 
the individually tagged objects) means that if the model is shared with a colleague they can use any of the tags in the 
group without having to create them themselves. 



  

The Explain tab in the Explorer panel provides a variety of descriptions of any object or effect in a model. As 
with the agent and effect views, this can be helpful in both understanding a model in text form, as well as 
generating simple text export for use in external documentation. 



  

Southbeach Modeller supports the concept of grids. These can be used to implement overlays for any visual model as either 
grids, pools, swimlanes or simple labelled boxes. The user specifies whether they need one or two axes, vertically (pools) or 
horizontally (swimlanes) and then specifies the axis labels.Objects inherit ‘tags’ from these values depending on their 
position on the canvas. A row or a column is a virtual tag group. The user is free to implement any consulting or analysis 
‘grid’ for their application or use case. As with normal tags, this metadata is available to the creativity/ideation engine. 



  

Southbeach comes pre-installed with a library of over 100 standard grids based on accepted consulting practice, e.g. a 
range of 2x2s. It is hard to overstate the importance of this feature. Southbeach visual models are not dumb diagrams. 
Grids add tag metadata to the model, simply by virtue of the position of objects on the grid canvas. These values can be 
referred to in creativity scripts, reporting templates and more. Thus, models become active as ideation is generated.



  

In this example, the user has added a grid to an existing model, thereby creating rows and columns 
according to a ‘horizon scanning’ project. The objects on the grid have therefore inherited tags from their 
position on the canvas. This is reflected in the Explorer panel – Agent list view ‘by column’. The integration of 
grids with tags, the creativity engine and views and sorts makes for a powerful way to package up ‘best 
practices’ as template Southbeach models. 



  

Cues in a major new function in v4 of the software. All pre-installed or user-defined cues definitions are displayed 
a tree, set out according to the grammar of the sentences to be generated. If the cues engine is on (icon in 
toolbar), sentence alternatives are generated as the user clicks around the model, similar to the way creativity 
works. Cues can be individually enabled or disabled as with creativity rulesets. In addition, cues can be 
customized by selecting or de-selecting combinations in the grammar. For example, if the cue defines 
combinations for ‘who’, ‘why’, when, ‘where’, ‘what’ questions (5whys), the user may choose at run time to only 
generate ‘why’ and ‘what’ questions. 



  

As we have explained, grids are implemented under the hood as virtual tags. If a model has a grid, the 
objects inherit the tags from the cell in which they appear. This means that agent views and sorts can list the 
objects according to the rows and columns in which they appear. 



  

This screenshot shows the main File menu. Note that as well as the normal function of opening a model, it is also 
possible to create a new model from an existing model, in effect using it as a template model. It is also possible to 
merge the content of an existing model with the current open model. Models can also be exported as images (both 
opaque and transparent), useful for insert into external documentation or to share on social channels. 



  

The View menu provides the usual cut/copy/paste functions for objects on the canvas and in other panels. 
Objects can also be ‘selected’ (given handles) according to their properties. For example, select a ‘useful 
goal’ on the canvas and then use ‘select like me’ and similar objects will be selected. 



  

The View menu provides access to the panel visibility controls as well as zoom level. Zoom normal is 100%. Zoom 
level is always displayed bottom left of the application window. As models grow or shrink it can be helpful to ‘fit to 
canvas’ or ‘trim canvas’ in areas where there are no visible objects. Pan/zoom and Fisheye tools are provided for 
navigating large, complex or detailed visual models. Icons for these two tools also appear in the toolbar. 



  

The Model menu provides access to dialogs for setting important attributes of a Southbeach model. This includes any agent 
or effect preferences, a visual style, grid properties, and auto-layout (if required).  Southbeach includes a powerful auto-
layout feature supporting a wide range of tree and graph behaviors. Toolbar icons are provided for ‘fixing up’ the layout of a 
messy tree or graph, for example, with a single click. Alternately ‘continuous’ auto-layout can be enabled. In addition, single 
click ‘spread’ and ‘compact’ functions expand or reduce the space between objects.  Certain objects can be ‘pinned’ (fixed 
position) or ‘clamped’ (free to be moved by the user but not the engine) within an auto-layout where required. 



  

Objects can be added to the canvas in numerous ways, including 1) ‘dragging out’ from an existing object to create 
a new object and its effect, 2) double-clicking on the canvas, 3) control keys (see separate guide), 4) using ‘assist 
tools’ (Toolbox panel) or 5) dragging items from any list of resources including ‘drilled down’ elements from existing 
models, from the tag library, the list library and more. However, the Insert menu is another way to create objects.  



  

The Format menu applies to currently selected objects and effects. In addition, right mouse on any object to 
access a function to set that object’s size to become the default size for new objects of the same notation 
type/shape. 



  

In addition to notation objects and effects, Southbeach Modeller provides a set of ‘drawing objects’. These have no 
semantic significance and are purely decorative. They exist in their own ‘layer’ of the model and so can be positioned 
independently without disturbing the model. Use the ESC key to complete shapes with N sides, e.g. polygon, flexigon.



  

The Tools menu provides access to a range of auxiliary functions. These include: 1) a research function that can use 
objects in the model to search web resources and patent databases, 2) transformations of the model, e.g. to increase 
ideality, 3) highlight individual objects or patterns (see default pattern, e.g. contradictions in the toolbar dropdown, 4) invoke 
dialogs to capture new objects or edit existing object names in bulk without the need to select each object individually, 5) 
access the global options for the software. 



  

As for many applications, Southbeach Modeller can cascade or tile (vertically or horizontally) the canvas when 
multiple models are open. Note, sub-models are always tabs in the same window (same .sbm file) allowing for 
one-click access. 
 



  

The Help menu provides access to online help for Southbeach Modeller. Please note the ‘check for new 
releases’ function. We particularly value feedback. The option makes this easy. Feedback is submitted via a web 
service directly to our database. A telephone icon in the toolbar performs the same function. 



  

The License menu provides options for accessing our shop, sending a unique site code for your system and 
activating a license key. We also encourage you to register your software. If your email address changes, 
please consider re-registering. If you need support, please use the menu option or write to 
support@southbeachinc.com. 

mailto:support@southbeachinc.com


  

The List library is new in v4. Organized as a tree, over 200 topic-specific 'lists' of reusable elements is provided, totaling 
10000s of items, each of which can be converted to objects with a single click or by dragging to the canvas. In addition, 
entire lists can be converted to objects in a single operation or ‘painting over’ the names of existing objects. A list is a simple 
.txt file. As with all other resource libraries/trees in Southbeach, the user is free to add content of their own. This will appear 
in the Toolbox trees as for the pre-installed content. Note, list trees and branches, as all resource trees, can also be copied 
to the system clipboard. 



  

The Creativity ruleset library has been significantly expanded in v4 of the software. It now totals 100s of carefully curated 
ideation scripts and rulesets, all searchable. These can be used ‘as is’ or as templates for producing your own customized 
ideation rules. As in v3, individual or multiple rulesets can be enabled. In v4, however, these selections are now persisted 
in the application environment. In addition, v4 makes it easy to copy rulesets into a model for sharing with anyone who has 
access to the model but not the local creativity library. Note, the new toolbar icons for turning on/off the ideation engine, 
model creativity and cues. 



  

Cues is a significant new function in v4 of the application. It complements the rules engine by allowing for the definition of 
sentence grammars that then generate multiple variations of the sentence template. The sentences generated an be used 
as extended rule sets, greatly increasing the ability of Southbeach to generate new ideas. Users turn on/off cues, or parts of 
cues, and the engine generates sentence alternatives as the user clicks around a model.  Cues can be instantly converted 
to a normal ruleset and added to a model. 



  

The Assist tools have been rationalized and re-arranged in v4 of the software. Assist tools perform transformations 
on a model. For example, by invoking ‘add outputs’ a new object is added everywhere one is required. As in v3, the 
assist function is intelligent and if the ‘missing only’ checkbox is ticked only necessary new objects will be created. 
Note also, Assist functions can operate on the whole model or a selected part or set of objects. 



  

In this example of using the ‘Assist tools’, ‘improving factors’ (new useful objects with a ‘countering’ effect on 
harmful objects) have been added to parts of the model where they are needed. The ‘highlight’ checkbox 
(bottom of the assist panel) is useful in order to clearly see the newly inserted objects. Remove highlights 
later in the normal way using the Toolbar ‘eraser’ icon. 



  

The Notes panel (right) is a convenient way to keep notes on the model and on any object or effect in the 
model. There are two tabs: model notes and ‘this’ notes (the selected object or effect). Just type into the 
panels as required. Right mouse for edit controls. In this screenshot an object is selected and its notes are 
shown in the ‘this’ panel. 



  

In this screenshot, a single effect in the model is being selected. It’s notes are shown in the ‘this’ panel (right 
hand side top). Below is ‘ideation’ associated with the element. This dynamic content is generated using the 
ruleset selected in the creativity panel. 



  

Many editing operations in Southbeach are completed using only the canvas. Right mouse on any object to 
access its context menu. The menu displays all of the available modifiers and attributes as well as the option 
of changing the objects type (shape). There are sub-menus for tagging, fixing and using object URLs.  



  

As with the agent context menu, effects also have a context menu. The menu displays all of the available 
modifiers and attributes as well as the option of changing the effect type (arrow style and semantic). In addition, 
convenient functions are providing for reversing the direction of an effect (A to B, B to A) and its semantic 
opposite or ‘counter’ effect. For example, a ‘creates’ effect would become a ‘destroys’ effect. An effect visual style 
sub-menu is also provided. 



  

In a model with multiple sub-models, each will be displayed in its own canvas tab. The tabs also have a 
context (right mouse) menu allowing tabs to be re-named, re-arranged, added, deleted and ‘separated’. The 
latter refers to associating the sub-model in its tab with a formal ‘separation’ of content. For example, a model 
containing three sub-models for ‘system’, ‘super-system’ and ‘sub-system’ might be separated by ‘structure’. 
This means that all elements in each sub-model inherit a ‘tag’ of those names in a tag group ‘structure’. This 
consistently extends all tagging and grid/chart functionality to sub-models. 



  

The ‘cloud’ icon in the Toolbar gives options for searching web resources and patent databases based on the 
names of objects and effects in the model. The drop down allows the user to select their preferred source. 
Thereafter, selecting an object or group of objects and then clicking on the cloud icon invokes the specified 
web search. Results are presented in the system web browser. Note, each agent and effect in the model has 
a URL attribute field to accompany any ‘this’ panel Notes. 



  

New in v4 is a powerful pattern-based highlighter. Every ‘derived’ parameter in the rules engine can be used 
to highlights agents that match that pattern in the model. As with all drop down menus from the toolbar, the 
user can select a preferred option which becomes a default for subsequent clicks on the icon. In the 
screenshot example, the user has found a ‘problem’ in the model and then used the arrow keys to follow 
highlighted causes and effects in the model. 



  

Models can be presented to an audience in ‘sequence’.  Building a sequence just means labeling the order in 
which individual objects or groups of objects are displayed. The build can then be ‘played’ using the tape 
recorder controls in the toolbar. The sequence is stored with the model (.sbm file). The ordering numbers only 
appear when the build dialog is invoked.  



  

Southbeach has an auto-layout function. Models can be free form, trees or graphs. The type of the model can be 
changed from the toolbar icon, the Model menu or the right mouse (context) on the canvas. Icons are provided to apply 
the format to the model following a change, or to turn on ‘continuous’ auto-format and to ‘spread’ or ‘compact’ the space 
between objects. The layout engine provides parameters able to emulate the look and feel of any different kinds of trees 
and graphs. Individual objects can also be ‘pinned’ or ‘clamped’ to exclude them from layout changes. The difference 
between ‘pinning’ and ‘clamping’ is that clamping allows the user to re-position an excluded object without ‘unpinning’ it. 



  

Auto-layout properties, in this case the graph properties, can be customized and stored with the model. They 
can be applied immediately, after the model has changed, or continuously during editing of the model. In the 
case of graphs, options are provided to fix the position of objects with certain attributes. This is a short cut to 
avoid ‘pinning’ or ‘clamping’. For example, fixing the ‘focus’ objects in the model while other object re-arrange 
themselves around them. 



  

As with graphs, tree properties can be customized and stored with the model to which they apply. They can 
be applied immediately, after the model has changed, or continuously during editing of the model. For 
example, adding new nodes to a tree will automatically re-arrange all other nodes to create enough space 
and avoid overlaps. The options for many different kinds of trees are beyond the scope of this document. 
Experimentation is encouraged. For example, the auto-layout engine knows about disconnected trees in a 
single model, as in this example. 



  

Southbeach Modeller is scalable, able to store and manipulate visual models containing 100s or 1000s of 
elements separated across multiple sub-models, all held in a single file (.sbm file, XML). Pan and Zoom (via 
tool bar or View menu) is sometimes required when navigating a large model, although use of the mouse 
wheel (Ctrl+wheel) and panning controls on the keyboard are often sufficient. 



  

From the View menu or toolbar icon (Eye) a fisheye magnifier is provided. This has proved useful for 
scanning detailed models and small font text, as well as during presentations. Ctrl+mouse wheel changes the 
degree of magnification. 



  

It is often convenient to capture information interactively during a working session. We call this ‘Live Capture’. 
The names of objects are simply typed into the dialog and can be added to the model at will. Two versions of 
‘Live Capture’ is provided: useful/harmful/neutral and sufficient/insufficient/surplus/potential/dysfunctional. This 
has proved ‘good enough’ for most workshop practices. Once the information has been captured as objects, they 
can be moved around and effects or relationships added. 



  

The multi-edit dialog (Tools menu) is a convenient way to edit or clean up the names of selected objects in 
the model, in one operation. The dialog lists all objects in the model. Once edits are made, changes are 
applied to the visual model. 



  

Lists are a major new function in v4. Over 200 lists are provided, covering a wide range of topics, giving 
access to 10000s of modelling elements. The role of these lists is to inspire modelling and creativity. 
Elements can be reused in models individually (just drag to the canvas) or as complete lists. A list can be 
converted to objects or used to paint over the names of existing objects. Lists are held in .txt files and the 
user can add their own preferred lists of resources to Modeller. They will appear in the Lists panel tree 
according to the hierarchy of folders used. 



  

As the user clicks around a model, and if the ideation engine is on (power icon in toolbar), ideas (sentences) 
are generated and displayed in the creativity panel (right). Sentences are output depending upon which rules 
match patterns in the model. The user has control of which parts of the model are used. This is called 
‘scope’. For example ‘laser’ instructs the engine only to fire on individual objects. ‘Narrow’ extends this to 
adjacent effects. ‘Wide’ includes adjacent objects, etc. ‘Widest’ applies the rules to the entire model. 



  

As well as the extensive library of creativity rulesets provided in the Toolbox panel, Southbeach also provides the concept of 
‘model creativity’. These are rules held in the model itself. Look at the panel on the right. It is split in two. The upper part are 
the model rules and the lower part the output. If ‘model creativity’ is enabled (icon in Toolbar) these local rules are 
combined with any library rules enabled. Thus, it is possible to develop a model or template containing all the rules 
necessary for its operation. The person who has the model does not need a corresponding library. In this example, the 
model rules are simply a copy from the library. But there is nothing to stop users modifying these or adding rules of their 
own creativity. Note, the upper panel can be hidden when not needed, thereby hiding the rules. A full manual (Creativity 
Reference) describing the powerful rules language is available separately.



  

The upper and lower parts of the Creativity panel have right mouse (context) menus. The upper panel (rules editor) has a 
‘Hide editor’ option and the lower panel (ideation output) has a ‘Show editor’ option. Note, function key F2 in either panel 
hides or shows the editor. 

Note that the Creativity panel has a tab to add [+] more output tabs. Each maintains it content across sessions and each 
serves the purpose of collecting content for each sub-model in the model (if any). The relationship between sub-model 
and output panel is automatic. Just click on the sub-model and output panel to see the associated ideation content. 



  

The lower (ideation output) part of the Creativity panel has a context menu for specifying the operation  and format of 
generated ideation. The panel can be set to append or replace new content as the user clicks around the model and 
new ideas are generated. Numbering, line spacing and style can be set. Style refers to different types of quotes marks 
or brackets placed around the names of objects inserted into the generated sentences. 

A ‘trace’ option appends the name of the ruleset that generated the sentence. 



  

Southbeach v4 now provides a search box in the toolbar, also available in the Edit menu – Find. This allows for 
searching by substring, exact string or notation pattern. All objects matching the text or pattern are selected in the 
model. To specify a notation pattern start with the ^ character, e.g. ^harmful+risk+@priority, would select all harmful 
risks tagged as priority. Note that if the model has a grid, the pattern can include the values of the row and column or 
labelled boxes tags. In addition, all derived keywords in the creativity engine are supported. For example, the pattern 
^contradiction+increasing would find all contradictions in the model (objects that are simultaneously improving and 
harming the system) and that are increasing in severity as a result of an increasing effect on them from another 
agent. (This new search functionality complements the existing (in v3) search by key letter. Type any key and the 
next object starting with that letter is selected on the canvas.)



  

Endorsement

✔ "I really like your software. It is an easy to use visual tool for working with all kinds of thinking 
methods." -- Creativity Consultant

✔ "A practical tool that guides where effort should be focused as problem-solving proceeds." -- 
Mind Mapping.Org

✔ "Southbeach has an important plus - the models are readily understood by non-technical 
employees" -- Business Manager

✔ "Southbeach is a superb notation for organizing your thoughts. An hour's Southbeach reduces 
task completion by days." -- Strategy Lead

✔ "A very neat tool for almost anything! I keep it open in the background all the time" -- Business 
Improvement Manager

✔ "The creativity manual is well written. The rules language is wonderfully simple yet powerful. It 
will be interesting to see what people do with this." -- Lead IT Strategy & Transformation

✔ "Remarkable. I learnt more from my models in ten minutes than weeks of previous looking." -- 
Innovation Consultant

✔ "I am very enamored with Southbeach. I use it in group situations. A telling indication (for me) is 
that most if not all of my "project" folders now contain a Southbeach sub-folder!" -- Business 
Analyst, ITIL and Six Sigma Black Belt

https://www.southbeachinc.com/customers.html 

https://www.southbeachinc.com/customers.html
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